Installing Jekyll

If you are using Python 3 as a standard, the Jekyll installation from homebrew might give you problems, because the Jekyll installation out-of-the box uses the syntax higlighter Pygments, which does not work under Python 3. This is the rather mysterious error I got:

$ jekyll serve --trace
Configuration file: /Users/mok/github/
Source: /Users/mok/github/
Destination: /Users/mok/github/
Liquid Exception: No header received back. in _posts/2015-05-02-welcome-to-jekyll.markdown

Instead, use the Ruby highlighter rouge. In _config.yml, add:

highlighter: rouge

and install the rouge highlighter gem:

gem install rouge

Now the installation should go without problems.